SEMESTER 2
ROUTING PROTOCOL AND CONCEPT
Chapter 1
Router component and function:
- CPU (Central Processing Unit) : execute operation system instruction, routing and switching function.
- RAM (Random Access Memory) : volatile memory, used to store these component :
- OS : IOS is copied into RAM when booting
- Running-configuration file : configuration that save running configuration (temporary configuration)
- IP routing table : save information about IP on the network which directly connected and remote network (determine best path to forward packet)
- ARP cache : cache that containing IPv4 address to MAC address table. like as ARP cache at PC. ARP cache is used on the router that have LAN interface (ethernet interface)
- Packet buffer : packet which temporary saved in buffer, when received from interface or before the packet out from interface.
- ROM (permanent storage) : cisco used for :
- The bootstrap instruction
- Basic diagonistic software
- Scaled down IOS version
modified or upgrade. Mini IOS located here.
4. Flash Memory (non-volatile memory) : Flash copied into RAM, then it will be executed by
CPU. Flash consist of SIMM / PCMCIA card which size can be upgraded.
5. NVRAM (non-volatile RAM) : NVRAM is used for startup-config
Bootup Process :
- Performing POST : check installed hardware
- Loading Bootstrap program : sequence of boot loader ex : firstbot, secondbot..
- Locating and Loading Cisco IOS : ussualy find IOS at Flash, but IOS can be found at TFTP (Trivial File Transfer Protocol)
- Locating and Loading startup config file : after IOS has been located, bootstrap program will find out startup config file in NVRAM include : interface address, routing information, password, and any config saved by Network Administrator.
Execute the configuration file
> if startup config found in NVRAM, IOS will load it into RAM as running config and execute that command sequential.
Enter Setup Mode (optional)
> if file configuration is not found, router will ask to user for input the basic config. example : would you like to enter the initial configuration dialog [yes/no] : ...
when setup mode not in use, IOS will make a default running config.
show version :
- IOS version
- bootstrap version
- model and CPU
- amount of RAM
- amount of NVRAM
- amount of Flash
- number and type of interface
Static Routing :
- If a network consist of few routers (using dynamic only increase an overhead)
- a network that connect to internet using only 1 ISP (no need dynamic because to connect an ISP only use one exit point/interface)
- a network that configured in hub and spoke topology (because a spoke only need 1 exit interface to connect a hub)
Dynamic Routing perform : network discovery and update / maintaining routing table. it runs with special algorithm.
Dynamic Routing Protocol :
- RIP (Routing Information Protocol)
- IGRP (Interior Gateway Routing Protocol)
- EIGRP (Enchanted Interior Gateway Routing Protocol)
- OSPF (Open Shortest Path First)
- IS-IS (Intermediate System to Intermediate System)
- BGP (Border Gateway Protocol)
Routing Table Principle (Alex Zinin) :
- Every router make their own decisions (based on information in the routing table) / independent with other router
- Every router manage their own routing table (every router must be configured, otherwise it's cannot connect between others)
- Every router must configured with reverse route (router cannot make their reverse route)
Asymetric Routing :
- router allowed have different routing table. packet may depart and arrive with different path.
- commonly used in internet that using BGP for routing.
Router choose "best path". every many path used to reach the network, path use different exit interface to reach the destination. best path selected based on value / metric
There are 2 function of Packet Forwarding :
- Path Determination : router search routing table for NA that match for destination IP.
- Directly Connected Network
- Remote Network, if destination ip is belong to remote network, packet will be forward to other router.
- No route determined, if destination ip is not belong to directly connected router or remote network and router dont have default route, then DROP packet, router will send ICMP unreachable to source packet.
- Switching Function : when router get the packet from FastEthernet, then the packet must be forwarded to other port. The main responsibility is encapsulate packet into data link frame for thrown out.
if router get packet from a network, then the packet addressed to different network, so the process are :
- Decapsulate or open layer 3 packet with erase layer 2 header frame and thrailer.
- Check destination IP to find the best path.
- Encapsulate layer 3 packet into layer 2 then forward the packet to exit interface.
when between router using serial cable, it doesn't require MAC, R1 already know that the packet sent from R2, so serial cable doesn't require Data Link layer and ARP process.
Chapter 2
show interface : show all interface, MAC address, etc.
show running-config : check running configuration
login synchronus : separate between input and output
show ip interface brief : show device status, up or down (L1 , L2)
physically, router connected to CSU / DSU first (clock rate settings)
to see DCE/DTE in a router, you can write command
#show controllers 'serial0/0/0'
to see realtime notification like new router connection you can write command
#debug ip routing to on and #undebug to off the notification.
CDP (Cisco Discovery Protocol) : record all information on directly connected network.
command : #show cdp neighbors
after you enter the command, deviceID, local interface, hold time, capability, platform , and portID will be shown.
CDP active by default, message will be sent periodically (CDP Advertisement)
to see cdp detail, write show cdp neighbors detail
to disable CDP globally : no cdp run
to disable CDP on interface : no cdp enable (config-if)
CDP Advertisement should be turned off, because neighbors device can see all information about our router.
Recursive Lookup : router have to read the routing table twice, because the router must find exit interface of destination network that caused by the writting of static IP route with next hop IP.
to prevent Recursive Lookup, set IP route with exit interface, but router cannot get the destination MAC address. (with ARP)
there is a condition where a static route must be written with next hop IP, the conditions prevailing at Multi Access topology, the destination router can be more than one in a network. so for prevent recursive lookup at multi access topology, ip route must be written with exit interface and next hop IP.
Classfull : don't read subnet mask and include subnet mask on update routing table (don't support VLSM)
Classless : read subnet and include it into update routing table
Interior Gateway Routing Protocol : Routing Protocol that connecting among router in the same Autonomus System
Exterior Gateway Routing Protocol : Routing Protocol that connecting between Autonomus System.
Autonomus System : a group of router / network device that located in the same administration area.
Discance Vector Routing Protocol : Routing protocol that only know direction and distance to destination network.
Division Based on IGP's (Interior Gateway Protocol) :
physically, router connected to CSU / DSU first (clock rate settings)
to see DCE/DTE in a router, you can write command
#show controllers 'serial0/0/0'
to see realtime notification like new router connection you can write command
#debug ip routing to on and #undebug to off the notification.
CDP (Cisco Discovery Protocol) : record all information on directly connected network.
command : #show cdp neighbors
after you enter the command, deviceID, local interface, hold time, capability, platform , and portID will be shown.
CDP active by default, message will be sent periodically (CDP Advertisement)
to see cdp detail, write show cdp neighbors detail
to disable CDP globally : no cdp run
to disable CDP on interface : no cdp enable (config-if)
CDP Advertisement should be turned off, because neighbors device can see all information about our router.
Recursive Lookup : router have to read the routing table twice, because the router must find exit interface of destination network that caused by the writting of static IP route with next hop IP.
to prevent Recursive Lookup, set IP route with exit interface, but router cannot get the destination MAC address. (with ARP)
there is a condition where a static route must be written with next hop IP, the conditions prevailing at Multi Access topology, the destination router can be more than one in a network. so for prevent recursive lookup at multi access topology, ip route must be written with exit interface and next hop IP.
Chapter 3
Routing Protocol : Protocol that functions to exchange routing table between router automatically with sending update to neighbor routers.
Classfull : don't read subnet mask and include subnet mask on update routing table (don't support VLSM)
Classless : read subnet and include it into update routing table
Interior Gateway Routing Protocol : Routing Protocol that connecting among router in the same Autonomus System
Exterior Gateway Routing Protocol : Routing Protocol that connecting between Autonomus System.
Autonomus System : a group of router / network device that located in the same administration area.
Discance Vector Routing Protocol : Routing protocol that only know direction and distance to destination network.
- Implemented in simple network (like hub and spoke)
- Simple concept than Link State Routing Protocol
- Slow Convergence
- Sending Periodic Update to router that directly connected
Link State Routing Protocol : Routing protocol that know all topology in a network
- Implemented in large network
- Require more knowledge
- Fast Convergence
Routing Protocol Function :
- Discover Remote Network
- Keep routing table up to date
- Choose best path to destination
- Search / determine backup path
Routing Protocol Component :
- Data Structure
- Algorithm (every dynamic routing have different algorithm)
- Routing Protocol Message (RPM) : can be use to discover neighbor
Static Routing
- Small routing table size
- Used for stub network
- Use single default route
- Advantages:
- Low CPU processing, didn't communicate with neighbor router, so the process can be smaller
- Administrator can understand all networks
- Easy to configure (no algorithm)
- Disadvantages :
- Need more time to configure
- For large network, there is an error potential
- If there is a problem, Admin must solve it themselves
- Limited Scalability
- We must know the configuration on network
Dynamic Routing
- Advantages :
- Less time configuration, when there is topology changed, admin should not be solve that.
- Routing protocol determining their own path, the possibility of error is small.
- Can be used in a large network, router can learn themselves.
- Disadvantages :
- Less secure, because it directly exchange the information of routing table, it can received fake path (data can be stolen)
Division Based on IGP's (Interior Gateway Protocol) :
- Distance Vektor Protocol
- use bellman-ford algorithm
- use hop-count
- use periodic update (send routing table update each period)
- only know information that given by neighbors router.
Hop Count
- RIP (max = 15)
- IGRP (max = 255)
Periodic Update
- RIP (send update every 30s)
- IGRP (send update every 90s)
- Link State Routing Protocol
- use SPF (Shortest Path First)
- know all topology in a network
- use Triggered update (update will be sent when topology change)
- Metric : distance between router (size), the smaller is better.
R 192.168.8.0 /24 [ 120/2 ]
[RIP] [AD / hop count]
Administrative Distance : trust value against routing protocol
first seen :
- Administrative Distance
- Metric
- Load balancing : traffic division into 2 or more interface to the same destination
Kind of Load Balancing :
- EQUAL Load Balancing : if there are more than 1 path to the same destination with same metric, traffic will be divided equally.
- UNEQUAL Load Balancing : if the metric is different, traffic will be divided equally (IGRP and EIGRP)
Chapter 4
DVRP is a routing protocol that only know direction and distance to the destination network / router
DVRP divided into 3 :
- RIP (Routing Information Protocol) :
- Routing update will be sent with broadcast (RIPv1) and multicast (RIPv2) every 30 seconds (periodic update),
- max hop count = 1,
- all information of routing table will be sent (all information)
- IGRP (Interior Gateway Routing Protocol) :
- Cisco Proprietary,
- periodic update every 90 seconds,
- no hop count,
- it's metric consist of Bandwidth, Load, Delay, and Reliability
- EIGRP (Enchanted Interior Gateway Routing Protocol) :
- Cisco Proprietary,
- unequal load balancing feature,
- hybrid routing protocol because it has advantages of DVRP and LSRP,
- fast convergence,
- low CPU processing,
- scalable,
- DUAL Algorithm ( Diffusing Update Algorithm ) for calculate the shortest route / metric,
- no periodic update (Triggered Update)
Advantages and Disadvantages of Distance Vector
(+)
(+)
- easy to implement and maintain
- use less resources
(-)
- slow convergence, because there is time for an update
- short scalability
- there is a possibility for routing loops (if routing table is not updated)
Cold Start : Router process to learn directly connected network, occurs when router start / boot-up (if there is configuration in NVRAM)
Timers on RIP :
- Invalid timer (180 seconds) : when information about a route not received for 180 seconds, so route will be marked with invalid / unusable
- Flush timer (240 seconds) : when information about a route not received for 240 seconds, route will be deleted
- Hold-down timer (180 seconds) : a method to prevent routing loop
EIGRP not sending Periodic update, but send with :
- Triggered update : sending update when topology change, unreliable
- Bounded update : sending update only to router that need
- Partial update : sending routing information that required only
- Random Jitter (RIP_JITTER) : to prevent collision when sending periodic update at multiaccess topology (Hub only) the mechanism is random periodic update between 25-30seconds / 0 - 15 % range update interval.
- Routing loop : a condition of packet looping between routers with no destination route, it cause spend resource of router and bandwidth.
The Mechanism to prevent routing loop at DVRP
- Routing loop : a condition of packet looping between routers with no destination route, it cause spend resource of router and bandwidth.
The Mechanism to prevent routing loop at DVRP
- Prevent count to infinity : when looping occurs, packet will be sent continuously until invalid hop count (16)
- Hold-down timer : dead route will be marked with "down" status and can active again when that interface is on or there is a route that destined to that network.
- Split Horizon : router will not send information about a route to interface which the router receive that information.
- Route Poisoning : Router will send invalid route information to all router in the network.
- Poison Reverse : Router will send invalid route information to neighbor router, to prevent wrong route.
- TTL in effect : when looping occurs, packet will be sent until TTL value is = 0
Chapter 5
RIPv1
Characteristic :
RIP operation :
Characteristic :
- use distance vector routing protocol
- use hop count as metric
- maximal route = 15 hop count, 16 is invalid / unreachable
- sending update via broadcast (30 seconds)
- use UDP (User Datagram Protocol) port 520. possible periodic update cannot be received
- classfull routing protocol
- by default-autosummarization
- Layer 2 Broadcast : FF:FF:FF:FF:FF:FF
- Layer 3 Broadcast 255.255.255.255
After R3 booting, R3 sending request Message and Replied with Reply Message
RIP command :
(config)#router rip
(config-router)#network [ directly connected NA ] this command will sending routing update information to the network which inserted before.
- show the routing protocol :
#show ip protocol
- show the path of update reception (every any changes)
#debug ip rip
- prevent sending update to an interface, so bandwidth usage can be reducted
#passive-interface [interface]
RIPv1 = classfull so, autosummarization will cause a problem at a network which connected to two different classfull / Discontinous network.
Boundary router : router that connecting two different classfull
Chapter 6
CIDR (Class Inter Domain Routing) : a method to summarize some route into one route, for save the routing table and traffic routing update.
Method to save IPv4 addressing :
- VLSM & CIDR
- NAT : IP Private to Public translation
- Private IP addressing, because existence of IP public is limited
Supernet : Network that has a smaller subnet mask than it's classfull network. usually supernet is result of summarization. example : 192.168.1.128 /20
Chapter 7
RIPv2
Characteristic :
- distance vector routing protocol
- classless routing protocol (support CIDR, VLSM, Supernet)
- use UDP (User Datagram Protocol) port 520. possible periodic update cannot be received
- hop count as metric
- maximal route = 15 hop count, 16 is invalid / unreachable
- update multicast (224.0.0.9) every 30 seconds
- by default autosummarization is active, but it can be deactive
- Authentification Feature for Security Routing update
Similarity RIPv1 & RIPv2 :
- distance vector routing protocol
- hop count as metric
- periodic update
- auto summarization by default
- support equal cost and load balancing
- max hop count = 15 , invalid = 16
Difference RIPv1 & RIPv2 :
multicast update RIPv2 (224.0.0.9) , RIPv1 broadcast (255.255.255.255)
auto summarization can be disable RIPv2 support authentification RIPv2 use classless routing protocol
Weakness of RIPv1 :
- not support prefix (discontinuous network)
- not support VLSM (send routing table to the same prefix)
- not support CIDR (Summarize route)
redistribute static : propagate static route
default information originate : propagate default route (0.0.0.0)
Change RIPv1 into RIPv2
(config-router)#router rip
(config-router)#version 2
(config-router)#no auto-summary
then show ip protocol to check, whether the version is same?
summary implementation on RIPv2
Method 1
- applicable if subnet mask >= major subnet
- RX(config-router)#network 10.0.0.0
- RX(config-if)#ip summary-address 10.0.0.0 255.255.252.0
- 255.255.252.0 is a result of summary between 10.0.1.0 and 10.0.2.0
Method 2
- applicable at all condition
- (config)#ip route 192.168.0.0 255.255.252.0
- (config-router)#redistribute static
---------
Chapter 8
Routing Table Structure
- Level 1 Route
- Default Route
- Supernet
- Network Route (subnet mask same with classfull network)
- Level 2 Route : network that have bigger subner mask than it's classfull network. example : 192.168.1.64 /26
- Ultimate Route : route which have an exit interface or next hop IP address
- Parent Route : route which have child route or didn't have exit interface (Level 1 Route!)
- Child Route : route under parent route and is a ultimate route
Router criteria in choosing a path in routing table is look the "longest match"
example :
destination IP : 172.16.1.10
- route 1 : 172.16.0.0 /16
- route 2 : 172.16.1.0 /24
- route 3 : 172.16.1.8 /29
router will choose route 3
Routing Behaviour : the way router read the routing table
- Classfull : packet that have been enter to child route, cannot return to parent route for read other route (the most spesific is read other child route) packet will not forwarded to default route, because it's stuck at child route
- Classless : packet that enter child route, can return to parent route for read other route.
Recursive Lookup Process
- Check level 1 route
- if match with level 1 ultimate route, forward the packet
- if match with level 1 parent route, continue to step 2
- Check child route
- if match with level 2 ultimate route, forward the packet
- if not match, continue to step 3
- Check routing behaviour
- classfull : DROP packet
- classless : back to parent, and find the default route
Chapter 8
EIGRP is a expansion of IGRP and it is a Cisco proprietary.
Differences between IGRP and EIGRP :
IGRP :
- Bellman-Ford Algorithm
- Classfull routing protocol
- Periodic Update
EIGRP :
- DUAL Algorithm (Diffusing Update Algorithm)
- Classless routing protocol
- Bounded Update
EIGRP Characteristic :
- Use RTP (Reliable Transfer Protocol) at it's Layer 4
- Bounded Update (only sending update to router that needs the information), Triggered Update (sending update if topology change), Partial Update (only sending information that required for other router)
- DUAL Algorithm for prevent routing loop
- have 3 table : Routing table, Neighbor table, and Topology table
- Authentification Feature for routing update security
- Auto summary can be disabled
- sending update multicast 224.0.0.10
Administrative Distance :
- Summary EIGRP : 5
- Internal EIGRP : 90
- External EIGRP : 170
EIGRP Features :
- PDM (Protocol Dependant Module) support multiple network protocol like IP, IPX, Apple Talk
- Support Unequal Cost and load balancing
- Save the backup path
- Combining Advantages of DVRP (easy to configure and low CPU usage) and LSRP (fast convergence and support complex topology)
EIGRP Table :
- Routing Table
- Neighbor Table : contain information about EIGRP router that directly connected. Router#show ip eigrp neighbor
- Topology Table : contain information about EIGRP router in a network (all router that use EIGRP will be shown). Router#show ip eigrp topology
EIGRP Packet Type :
- Hello Packet : to establish connection with directly connected network and maintain that connection.
for Bandwidth > 1.544 Mbps (T1) : Hello Interval = 5 seconds , Hold Time = 15 seconds
for Bandwidth < 1.544 Mbps (T1) : Hello Interval = 60 seconds , Hold Time = 180 seconds
Hello Interval : interval of sending Hello Packet
Hold Time : maximum time before a route is declared down, and sending QUERY packet
- Update Packet : sending update to other router that use EIGRP
- Query Packet : asking to other router about existence of a network, if there is a router that declared down
- Reply Packet : reply Query Packet
- Acknowledge Packet : give ACK all EIGRP packet, except Hello Packet
Algorithm DUAL (DUAL FSM <Finite State Machine>)
- Successor : Primary Route (directly)
- Feasible Successor : Backup Route
- Feasible Distance : Distance from source to destination
- Reported Distance / Advertised Distance : Distance directly connected router to destination
- Feasible Condition : Terms for a path to become a Feasible Successor
[ FC = RD < FD ]
Successor & Feasible Successor stored in Topology Table
note :
- P (Passive) : DUAL's calculation is completed and can be used
- A (Active) : DUAL's calculations is being performed
- EIGRP Settings :
Router(config)#router eigrp [as number 1 - 65535]
Router(config-router)#no auto-summary
Router(config-router)#network [directly connected] [wildcard mask]
note:
AS number function is to distinguish the instance for each EIGRP routing process
Wildcard mask function is to limit the range of IP
- Change Hello Interval and Hold Timer :
Router(config)#interface [interface slot / port]
Router(config-if)#ip hello-interval eigrp [as number] [time in second]
Router(config-if)#ip hold-time eigrp [as number] [time in second]
- Passive Interface Setting
Router(config-router)#passive-interface [interface slot / port]
- Propagate Summary Route
- Method 1 :
Router(config)#interface [interface slot / port], interface to be propagated
Router(config-if)#ip summary-address eigrp [as number] [network]
note : network address that want to be summarized must be insert to EIGRP routing table (directly connected route will be assumed as Internal EIGRP)
- Method 2 :
Router(config)#ip route [NA] [SM] [exit interface | next hop IP]
Router(config)#router eigrp [as number]
Router(config-router)#redistribute static
note : network address that want to be summarized should not be insert to EIGRP routing table, route will be assumed as External EIGRP
- Propagate Default Route :
- Method 1 :
Router(config)#ip route 0.0.0.0 0.0.0.0 [exit interface | next hop ip]
Router(config)#router eigrp [as number]
Router(config-router)#network 0.0.0.0
note : default route will be assumed as Internal EIGRP
- Method 2 :
Router(config)#ip route 0.0.0.0 0.0.0.0 [exit interface | next hop IP]
Router(config)#router eigrp [as number]
Router(config-router)#redistribute static
note : default route will be assumed as External EIGRP and all of static route will be routed
- Change bandwidth on interface :
Router(config-if)#bandwidth [bandwidth in kbps]
- Bandwidth Utilization (bandwidth limitation)
Router(config-if)#ip bandwidth-percent eigrp [as number] [percent]
- Troubleshoting :
Router#show ip route
Router#show ip protocol
Router#debug eigrp [packet | fsm]
Router#show running-config
Chapter 10
Link State Routing Protocol
- Djikstra Algorithm (SPF) Shortest Path First
- No Periodic Update, update at the first time and when topology change
5 Steps of Link State running the routing protocol :
- Link State learn a network which directly connected
- Send hello packet to neighbor, but ethernet not reply the hello packet, because it's an end device
- Building Link State Packet (contains all information that have been learned at step one) example : R1 -> R2 , learn ip, cost, but only the directly connected
- Sending LSP (Flooding LSP), sending packet to neighbor (packet will be forwarded to all branch router) when neighbor receive LSP, then LSP will be copied to database then forwarded
- After LSP have been received on the router, so router create it's own database and calculate the best path.
Advantages of Link State :
- Every router has a complete description of topology
- Flooding LSP, fast convergence, directly copied, then flooding, and calculated (not checked with routing table)
- Link State only send the change of information network (triggered update)
- Link State has area division / area number, if router has a complete description of topology, so the performance becomes heavy, so the descriptions will be assumed per area, so save the CPU usage
- Link State used big memory and bandwidh for building the complete description of topology
Chapter 11
OSPF (Open Shortest Path First)
Characteristic :
- Link State Routing Protocol
- Classless Routing Protocol
- update multicast 224.0.0.5 & 224.0.0.6
- use Djikstra Algorithm for calculate the metric
- use cost as metric
- Administrative Distance = 110
- Authentification Feature
5 Type of OSPF Link State Packet (make adjacency)
1.Hello Packet : establish and maintain connection with other OSFP router
Broadcast Multiaccess & point to point network, Hello = 10 seconds, dead = 40 seconds
Non-Broadcast Multiaccess, Hello = 10 seconds, dead = 120 seconds
Hello Interval : Hello packet's interval
Dead Interval : maximum time before a neighbor assumed down
2. Database Description (DBD) : contains a summary of router's routing table , used for synchronize the database between router (sent at paranoid update 30 minutes)
3. Link State Request (LSR) : ask about contains of an entry in a DBD, when the contains of DBD is different from other router
4. Link State Update (LSU) : a group of Link State Advertisement, this packet is a reply of Link State Request (LSR) to give a new information.
5. Link State Acknowledgement : give an acknowledge to all packet, except Hello Packet.
- Link State Advertisement : contains information about neighbor network (cost). there are 11 Type of Link State Advertisement
Hello Packet Function
1. Establish and maintain connection
2. Make adjacent between routers :
- same hello time
- same dead time
- same area
- same network type
- same version
- same authentification
- same network mask
- DR : Router that distributed LSA packet, DR router is a central of settings
- BDR : Backup DR
- DR other : other router except DR and BDR
- DR send to BDR and DR other using 224.0.0.5
- DR other send to DR and BDR using 224.0.0.6
DR - BDR elections :
1. Highest router priority : default 1
Manual command : router(config-if)#ip ospf priority [0-255]
2. Highest router ID :
- Manual command : router(config-router)#router-id [ip]
- Highest loopback interface IP
- Highest Physical interface IP, if there is a PC
- note : router ID must not be same and DR/BDR will not change except DR / BDR down
Force DR/BRD election : shutdown - no shutdown an interface , the sequence : DR, BDR, DR Other
5 Network Type on OSPF :
- Point to Point
- Broadcast Multiaccess
- Non Broadcast Multiaccess
- Point to Multipoint
- Virtual Links
at BMA and NBMA there are DR and BDR
at multiaccess network, routers will perform adjacencies for several times or exchange the LSP (LSA) the formula to calculate the number of adjacencies is n(n-1) / 2
n = number of router
Reference Bandwidth : in order to bandwidth that bigger than 100Mbps has a smaller cost than 100Mbps.
by default, for bandwidth >= 100Mbps, cost = 1
Router(config-router)#auto-cost reference bandwidth (1-4294969 in Mbps)
Basic command OSPF
Router(config)#router ospf [process id, 1-65535]
Router(config-router)#network [NA] [WM] area [area no]
note : to distinguish between instance used process ID, to limit the network that will be distributed used WM
Change cost :
Router(config-if)#bandwidth [kpbs]
Router(config-if)#ip ospf cost [cost]
Propagate default route :
Router(config-router)#default information originate
note : will be shown O*E2 on the routing table, E2 is OSPF external type 2 which it's cost is summed with link cost to router which propagate that route.
Propagate static route :
Router(config)#ip route [NA] [SM] [exit interface | next hop]
Router(config)#router ospf [process id]
Router(config-router)#redistribute static subnets, if 'subnets' command didn't exist, so NA will be converted to classfull.
Change Hello and Dead Timers :
Router(config-if)#ip ospf hello-interval [seconds]
Router(config-if)#ip ospd dead-interval [seconds]
Troubleshoting OSPF :
Router#show ip route
Router#show ip protocols
Router#show ip ospf interface [interface slot/port] show hello and dead interval
Router#show ip ospf neighbor
Router#show ip ospf database
note : to distinguish between instance used process ID, to limit the network that will be distributed used WM
Change cost :
Router(config-if)#bandwidth [kpbs]
Router(config-if)#ip ospf cost [cost]
Propagate default route :
Router(config-router)#default information originate
note : will be shown O*E2 on the routing table, E2 is OSPF external type 2 which it's cost is summed with link cost to router which propagate that route.
Propagate static route :
Router(config)#ip route [NA] [SM] [exit interface | next hop]
Router(config)#router ospf [process id]
Router(config-router)#redistribute static subnets, if 'subnets' command didn't exist, so NA will be converted to classfull.
Change Hello and Dead Timers :
Router(config-if)#ip ospf hello-interval [seconds]
Router(config-if)#ip ospd dead-interval [seconds]
Troubleshoting OSPF :
Router#show ip route
Router#show ip protocols
Router#show ip ospf interface [interface slot/port] show hello and dead interval
Router#show ip ospf neighbor
Router#show ip ospf database
BROADCAST MULTIACCESS AND NON BROADCAST MULTIACCESS IMAGES
Redistributing Routing Protocol
1. EIGRP -> OSPF
(config)#router ospf [process id]
(config-router)#redistribute eigrp [as number] metric [cost] subnets
2. OSPF ->EIGRP
(config)#router eigrp [as number]
(config-router)#redistribute ospf metric [bandwitdh] [delay] [reliability] [load] [MTU]
3. EIGRP -> RIP
(config)#router rip
(config-router)#redistribute eigrp [as number] metric [hop count]
4. RIP -> EIGRP
(config)#router eigrp [as number]
(config)#redistribute rip metric [bandwitdh] [delay] [reliability] [load] [MTU]
5. OSPF -> RIP
(config)#router rip
(config-router)#redistribute ospf [process id] metric [hop count]
6. RIP -> OSPF
(config)#router ospf [process id]
(config-router)#redistribute rip metric [cost] subnets
7. Static Redistribute
(config)#ip route [summary NA] [SM] null 0
(config-router)#redistribute static
example :
OSPF -> EIGRP
(config)#router eigrp 1
(config-router)#redistribute ospf 1 metric 6400 1 255 1 1500
7. Static Redistribute
(config)#ip route [summary NA] [SM] null 0
(config-router)#redistribute static
example :
OSPF -> EIGRP
(config)#router eigrp 1
(config-router)#redistribute ospf 1 metric 6400 1 255 1 1500
OR
(config)#ip route 192.168.0.0 255.255.255.0 null 0
(config)#router eigrp 1
(config-router)#redistribute static
Tidak ada komentar:
Posting Komentar